router cisco
На страницу Пред.  1, 2
 
Начать новую тему   Ответить на тему    Список форумов -> Софт, железо, и всё, что связано с ним
::  
Автор Сообщение
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Ср Дек 03, 2008 8:25 am    Заголовок сообщения: Ответить с цитатой

а когда? Я просто проверял в понедельник вечером..
Убрал unicast route?
Сегодня попробую еще..
Посмотреть профиль Отправить личное сообщение Отправить e-mail
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Ср Дек 03, 2008 7:23 pm    Заголовок сообщения: Ответить с цитатой

на домашнем ПК проверил маршрутизацию:

C:\Documents and Settings\user>route print
===========================================================================
Список интерфейсов
0x1 ........................... MS TCP Loopback interface
0x10003 ...YY YY YY YY YY YY ...... Intel(R) InBusiness(TM) 10/100 Network Adapt
er #2
===========================================================================
===========================================================================
Активные маршруты:
Сетевой адрес Маска сети Адрес шлюза Интерфейс Метрика
0.0.0.0 0.0.0.0 172.17.171.1 172.17.171.X 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
172.17.0.0 255.255.0.0 172.17.171.1 172.17.171.X 1
172.17.171.0 255.255.255.0 172.17.171.X 172.17.171.X 20
172.17.171.X 255.255.255.255 127.0.0.1 127.0.0.1 20
172.17.255.255 255.255.255.255 172.17.171.X 172.17.171.X 20
172.18.0.0 255.255.0.0 172.17.171.1 172.17.171.X 1
192.168.1.0 255.255.255.0 172.17.171.1 172.17.171.X 1
192.168.1.1 255.255.255.255 172.17.171.1 172.17.171.X 1
192.168.1.11 255.255.255.255 172.17.171.1 172.17.171.X 1
192.168.1.100 255.255.255.255 172.17.171.1 172.17.171.X 1
192.168.1.101 255.255.255.255 172.17.171.1 172.17.171.X 1
224.0.0.0 240.0.0.0 172.17.171.X 172.17.171.X 20
255.255.255.255 255.255.255.255 172.17.171.X 172.17.171.X 1
Основной шлюз: 172.17.171.1
===========================================================================
Постоянные маршруты:
Отсутствует



видно что действительно однохостовые ненужные маршруты удалены.

подключил роутер Cisco 806
интерфейс E1 настроен:

!
interface Ethernet1
mac-address YYYY.YYYY.YYYY
ip address dhcp client-id Ethernet1
!
проверяю состояние интерфейса E1:

Router#show int e1
Ethernet1 is up, line protocol is up
Hardware is PQUICC_FEC, address is YYYY.YYYY.YYYY (bia MMMM.MMMM.MMMM)
Internet address is 172.17.171.X/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 10Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:07, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
78 packets input, 7968 bytes, 0 no buffer
Received 78 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
20 packets output, 4095 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred

Router#

DHCP-адрес получен!
Ураааа! Smile
Резюме - дело было в лишних однохостовых маршрутах.
maxim'у - спасибо.
ждите продолжение темы..
Посмотреть профиль Отправить личное сообщение Отправить e-mail
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Ср Дек 03, 2008 10:28 pm    Заголовок сообщения: Ответить с цитатой

может кому-то из энтузиастов будет интересен дебаг роутера Cisco на этапе получения IP-адреса от Бризового DHCP-серсера.
Видно как проходят все этапы получения адреса - DHCPDISCOVER, DHCPOFFER, DHCPREQUEST и DHCPACK.
Привожу:

*Mar 1 00:09:45.555: DHCP: Try 12 to acquire address for Ethernet1
*Mar 1 00:09:45.559: DHCP: allocate request
*Mar 1 00:09:45.559: DHCP: new entry. add to queue
*Mar 1 00:09:45.559: DHCP: SDiscover attempt # 1 for entry:
*Mar 1 00:09:45.559: Temp IP addr: 0.0.0.0 for peer on Interface: Ethernet1
*Mar 1 00:09:45.559: Temp sub net mask: 0.0.0.0
*Mar 1 00:09:45.563: DHCP Lease server: 0.0.0.0, state: 1 Selecting
*shMar 1 00:09:45.563: DHCP transaction id: 5558
*Mar 1 00:09:45.563: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs
*Mar 1 00:09:45.563: Next timer fires after: 00:00:02
*Mar 1 00:09:45.567: Retry count: 1 Client-ID: XXXX.XXXX.XXXX
*Mar 1 00:09:45.567: Hostname: Router
*Mar 1 00:09:45.567: DHCP: SDiscover: sending 278 byte length DHCP packet
*Mar 1 00:09:45.567: DHCP: SDiscover 278 bytes
*Mar 1 00:09:45.567: B'cast on Ethernet1 interface from 0.0.0.0
*Mar 1 00ow :09:45.595: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:45.595: DHCP: Scan: Message type: DHCP Offer
*Mar 1 00:09:45.595: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:45.595: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:45.595: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:45.595: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:45.599: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:45.599: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:45.599: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:45.603: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:45.603: DHCP: rcvd pkt source: 172.16.128.227, destination: 255.
255.255.255
*Mar 1 00:09:45.603: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:45.607: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:45.607: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:45.607: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:45.607: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:45.607: srvr: 0.0.0.0, gw: 172.16.128.227
*Mar 1 00:09:45.611: options block length: 112

*Mar 1 00:09:45.611: DHCP Offer Message Offered Address: 172.17.171.Y
*Mar 1 00:09:45.611: DHCP: Lease Seconds: 6000
*Mar 1 00:09:45.611: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:45.611: DHCP: offer received from 172.16.128.2
*Mar 1 00:09:45.615: DHCP: SRequest attempt # 1 for entry:
*Mar 1 00:09:45.615: Temp IP addr: 172.17.171.Y for peer on Interface: Ethern
et1
*Mar 1 00:09:45.615: Temp sub net mask: 255.255.255.0
*Mar 1 00:09:45.615: DHCP Lease server: 172.16.128.2, state: 2 Requesting
*Mar 1 00:09:45.619: DHCP transaction id: 5558
*Mar 1 00:09:45.619: Lease: 6000 secs, Renewal: 0 secs, Rebind: 0 secs
*Mar 1 00:09:45.619: Next timer fires after: 00:00:01
*Mar 1 00:09:45.619: Retry count: 1 Client-ID: XXXX.XXXX.XXXX
*Mar 1 00:09:45.619: Hostname: Router
*Mar 1 00:09:45.623: DHCP: SRequest- Server ID option: 172.16.128.2
*Mar 1 00:09:45.623: DHCP: SRequest- Requested IP addr option: 172.17.171.Y
*Mar 1 00:09:45.623: DHCP: SRequest placed lease len option: 6000
*Mar 1 00:09:45.623: DHCP: SRequest: 296 bytes
*Mar 1 00:09:45.623: DHCP: SRequest: 296 bytes
*Mar 1 00:09:45.627: B'cast on Ethernet1 interface from 0.0.0.0
*Mar 1 00:09:45.627: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:45.627: DHCP: Scan: Message type: DHCP Offer
*Mar 1 00:09:45.627: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:45.631: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:45.631: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:45.631: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:45.631: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:45.631: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:45.635: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:45.635: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:45.643: DHCP: rcvd pkt source: 172.16.129.66, destination: 255.2
55.255.255
*Mar 1 00:09:45.643: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:45.643: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:45.643: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:45.647: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:45.647: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:45.647: srvr: 0.0.0.0, gw: 172.16.129.66
*Mar 1 00:09:45.647: options block length: 112

*Mar 1 00:09:45.651: DHCP Offer Message Offered Address: 172.17.171.Y
*Mar 1 00:09:45.651: DHCP: Lease Seconds: 6000
*Mar 1 00:09:45.651: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:45.651: DHCP: offer received from 172.16.128.2
*Mar 1 00:09:45.651: DHCP: offer received in bad state: Requesting punt
*Mar 1 00:09:45.655: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:45.655: DHCP: Scan: Message type: DHCP Offer
*Mar 1 00:09:45.655: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:45.655: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:45.655: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:45.659: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:45.659: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:45.659: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:45.659: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:45.659: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:45.659: DHCP: rcvd pkt source: 172.16.128.245, destination: 255.
255.255.255
*Mar 1 00:09:45.659: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:45.663: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:45.663: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:45.663: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:45.663: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:45.663: srvr: 0.0.0.0, gw: 172.16.128.245
*Mar 1 00:09:45.667: options block length: 112

*Mar 1 00:09:45.667: DHCP Offer Message Offered Address: 172.17.171.Y
*Mar 1 00:09:45.667: DHCP: Lease Seconds: 6000
*Mar 1 00:09:45.667: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:45.667: DHCP: offer received from 172.16.128.2
*Mar 1 00:09:45.671: DHCP: offer received in bad state: Requesting punt
*Mar 1 00:09:45.675: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:45.675: DHCP: Scan: Message type: DHCP Ack
*Mar 1 00:09:45.675: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:45.679: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:45.679: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:45.679: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:45.679: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:45.683: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:45.683: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:45.683: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:45.687: DHCP: rcvd pkt source: 172.16.128.245, destination: 255.
255.255.255
*Mar 1 00:09:45.687: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:45.687: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:45.687: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:45.691: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:45.691: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:45.691: srvr: 0.0.0.0, gw: 172.16.128.245
*Mar 1 00:09:45.691: options block length: 112

*Mar 1 00:09:45.695: DHCP Ack Message
*Mar 1 00:09:45.695: DHCP: Lease Seconds: 6000
*Mar 1 00:09:45.695: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:48.695: DHCP: Releasing ipl options:
*Mar 1 00:09:48.695: DHCP: Applying DHCP options:
*Mar 1 00:09:48.699: Setting default_gateway to 172.17.171.1
*Mar 1 00:09:48.699: Adding default route 172.17.171.1
*Mar 1 00:09:49.707: Adding route to DHCP server 172.16.128.2 via Ethernet1 1
72.17.171.1
*Mar 1 00:09:49.707: Adding static route to 192.168.1.1 255.255.255.255 via 1
72.17.171.1
*Mar 1 00:09:49.711: Adding static route to 192.168.1.11 255.255.255.255 via
172.17.171.1
*Mar 1 00:09:49.711: Adding DNS server address 192.168.1.1
*Mar 1 00:09:49.711: Adding DNS server address 192.168.1.11
*Mar 1 00:09:49.711: Setting default domain to cable.breezein.net
*Mar 1 00:09:49.715: DHCP Client Pooling: ***Allocated IP address: 172.17.171.1
7
*Mar 1 00:09:49.715: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:49.715: DHCP: Scan: Message type: DHCP Ack
*Mar 1 00:09:49.715: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:49.719: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:49.719: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:49.719: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:49.719: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:49.723: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:49.723: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:49.723: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:49.727: DHCP: rcvd pkt source: 172.16.128.227, destination: 255.
255.255.255
*Mar 1 00:09:49.727: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:49.727: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:49.727: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:49.727: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:49.731: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:49.731: srvr: 0.0.0.0, gw: 172.16.128.227
*Mar 1 00:09:49.731: options block length: 112

*Mar 1 00:09:49.731: DHCP Ack Message
*Mar 1 00:09:49.731: DHCP: Lease Seconds: 6000
*Mar 1 00:09:49.735: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:49.735: DHCP: rcv ack in Bound state: punt
*Mar 1 00:09:49.735: DHCP: Received a BOOTREP pkt
*Mar 1 00:09:49.735: DHCP: Scan: Message type: DHCP Ack
*Mar 1 00:09:49.735: DHCP: Scan: Server ID Option: 172.16.128.2 = AC108002
*Mar 1 00:09:49.739: DHCP: Scan: Lease Time: 6000
*Mar 1 00:09:49.739: DHCP: Scan: Subnet Address Option: 255.255.255.0
*Mar 1 00:09:49.739: DHCP: Scan: DNS Name Server Option: 192.168.1.1, 192.168.1
.11
*Mar 1 00:09:49.739: DHCP: Scan: Domain Name: cable.breezein.net
*Mar 1 00:09:49.739: DHCP: Scan: Router Option: 172.17.171.1
*Mar 1 00:09:49.743: DHCP: Scan: Static Route Option: 192.168.1.1 172.17.171.1
*Mar 1 00:09:49.743: DHCP: Scan: Static Route Option: 192.168.1.11 172.17.171.1
, &192.168.1.100&, &172.17.171.1&
*Mar 1 00:09:49.743: DHCP: rcvd pkt source: 172.16.129.66, destination: 255.2
55.255.255
*Mar 1 00:09:49.747: UDP sport: 43, dport: 44, length: 360
*Mar 1 00:09:49.747: DHCP op: 2, htype: 1, hlen: 6, hops: 2
*Mar 1 00:09:49.747: DHCP server identifier: 172.16.128.2
*Mar 1 00:09:49.747: xid: 5558, secs: 0, flags: 8000
*Mar 1 00:09:49.751: client: 0.0.0.0, your: 172.17.171.Y
*Mar 1 00:09:49.751: srvr: 0.0.0.0, gw: 172.16.129.66
*Mar 1 00:09:49.751: options block length: 112

*Mar 1 00:09:49.751: DHCP Ack Message
*Mar 1 00:09:49.751: DHCP: Lease Seconds: 6000
*Mar 1 00:09:49.751: DHCP: Server ID Option: 172.16.128.2
*Mar 1 00:09:49.755: DHCP: rcv ack in Bound state: punt
*Mar 1 00:09:49.823: Allocated IP address = 172.17.171.Y 255.255.255.0

*Mar 1 00:09:49.823: %DHCP-6-ADDRESS_ASSIGN: Interface Ethernet1 assigned DHCP
address 172.17.171.Y, mask 255.255.255.0, hostname Router
Посмотреть профиль Отправить личное сообщение Отправить e-mail
Maxim
Админ форума


Зарегистрирован: 03.10.2003
Сообщения: 404

СообщениеДобавлено: Ср Дек 03, 2008 11:40 pm    Заголовок сообщения: Ответить с цитатой

bag писал(а):
Резюме - дело было в лишних однохостовых маршрутах.


нет ничего лишнего, дело в кривизне dhcp client cisco

как видно из лога cisco переварила только 2 static route ... по каким стандартам они писали свой dhcp client вообще не понятно ...
Посмотреть профиль Отправить личное сообщение
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Чт Дек 04, 2008 11:25 pm    Заголовок сообщения: Ответить с цитатой

я внимательней посмотрел таблицу маршрутизации домашнего ПК и увидел что удалены не все однохостовые маршруты. По прежнему присутствуют однохостовые маршруты наряду с сетевым маршрутом.
Однохостовые
192.168.1.1 255.255.255.255 172.17.171.1
192.168.1.11 255.255.255.255 172.17.171.1
192.168.1.100 255.255.255.255 172.17.171.1
192.168.1.101 255.255.255.255 172.17.171.1
и сетевой маршрут
192.168.1.0 255.255.255.0 172.17.171.1

роутер Cisco действительно переварил не все маршруты которые ему пытается скормить DHCP-сервер.
Вот цисковая таблица маршрутизации:
Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.17.171.1 to network 0.0.0.0

172.17.0.0/24 is subnetted, 1 subnets
C 172.17.171.0 is directly connected, Ethernet1
172.16.0.0/32 is subnetted, 1 subnets
S 172.16.128.2 [254/0] via 172.17.171.1, Ethernet1
C 192.168.254.0/24 is directly connected, Ethernet0
192.168.1.0/32 is subnetted, 2 subnets
S 192.168.1.11 [254/0] via 172.17.171.1
S 192.168.1.1 [254/0] via 172.17.171.1
S* 0.0.0.0/0 [254/0] via 172.17.171.1
Router#

Я не пытаюсь защитить Cisco, но думаю что роутеру ничего, кроме маршрута по умолчанию
S* 0.0.0.0/0 [254/0] via 172.17.171.1
не надо, а раздавать DHCP-клиентам в виде опций кучу пересекающихся статических маршрутов считаю "дурным тоном".
Хотя я не знаю бризовую топологию сети.

Как у классика - а сервер кто (DHCP)?
Посмотреть профиль Отправить личное сообщение Отправить e-mail
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Вс Дек 07, 2008 9:08 pm    Заголовок сообщения: Ответить с цитатой

пока админы пытаются узнать реализацию своего DHCP-сервера я наконец-то добрался до своего роутера Cisco 806 чтобы настроить для работы в сети БРИЗ Smile IT-шутка

Так как на внешний интерфейс роутера E1 от DHCP-сервера уже приходит адрес, то я на ПК настроил статический адрес 192.168.254.10/24 (она же 255.255.255.0), шлюз 192.168.254.1 - это внутренний адрес роутера (интерфейс E0) и DNS-сервера прописал бризовые 192.168.1.1 и 192.168.1.11

Подключил патчкорд от ПК к интерфейсу Е0 роутера и стал в гипертерминале через консольный порт править конфигурацию роутера.
Прописал внутренний айпишник, пропинговал ПК, с ПК пропинговал внутренний и внешний интерфейсы роутера. Шлюз бриза естественно не пингуется, т.к. ему ничего не известно о моей 192.168.254.0 сети.
Надо либо просить админа чтобы он прописывал во всех своих роутерах маршруты на мою сеть, что конечно же нереально Smile либо настраивать трансляцию моих внутренних адресов во внешний адрес полученный от DHCP-сервера, что я и сделал.

на внутреннем интерфейсе Е0 включаем трансляцию
ip nat inside
на внешнем интерфейсе E1 включаем трансляцию
ip nat outside

активируем трансляцию адресов указанных в листе 1 через внешний интерфейс
ip nat inside source list 1 interface Ethernet1 overload

указываем в листе 1 адреса которым разрешено выходить через NAT
access-list 1 permit 192.168.254.10

это адрес ПК

сохраняем конфигурацию
copy run start

визуально проверяем конфигурацию
show run

С ПК снова пингуем бризовый шлюз - он отвечает. Теперь доступны ресурсы веб портала Бриз. Установка VPN-сессии проходит без вопросов - теперь доступен и интернет Smile
Думаю с другими сервисами проблем не должно быть.

Вот итоговая конфигурация роутера:

Current configuration : 684 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.254.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface Ethernet1
mac-address XXXX.XXXX.XXXX
ip address dhcp client-id Ethernet1
ip nat outside
!
ip nat inside source list 1 interface Ethernet1 overload
ip classless
ip http server
no ip http secure-server
!
access-list 1 permit 192.168.254.10
!
line con 0
stopbits 1
speed 19200
line vty 0 4
login
!
scheduler max-task-time 5000
end

Router#

продолжение следует Smile
Посмотреть профиль Отправить личное сообщение Отправить e-mail
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Пт Дек 19, 2008 11:14 pm    Заголовок сообщения: Ответить с цитатой

естественно не работает сервис IPTV - надо настроить маршрутизацию мультикаста. Есть рекомендации? какую версию igmp включать?
Посмотреть профиль Отправить личное сообщение Отправить e-mail
bag
Участник


Зарегистрирован: 25.11.2008
Сообщения: 22
Откуда: Украина, Одесса

СообщениеДобавлено: Пт Янв 02, 2009 9:36 am    Заголовок сообщения: iptv через роутер Cisco Ответить с цитатой

настроил маршрутизацию мультикаста так:

В глобал конфиг моуде включить роутинг мультикаста

ip multicast-routing

на обоих интерфейсах включить PIM в смешаном режиме

ip pim sparse-dense-mode

на внешнем интерфейсе прописать адрес хелпер-адрес указав свой шлюз по умолчанию
у меня это так

ip igmp helper-address 172.17.171.1

проверяем работу командой
show ip igmp int eX, где X-номер интерфейса

Сохраняем конфигурацию и запуская на ПК VLC проверяем работу.
Посмотреть профиль Отправить личное сообщение Отправить e-mail
Показать сообщения:   
Начать новую тему   Ответить на тему    Список форумов -> Софт, железо, и всё, что связано с ним
На страницу Пред.  1, 2
Страница 2 из 2

 
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы можете редактировать свои сообщения
Вы можете удалять свои сообщения
Вы не можете голосовать в опросах